solution.md 2.3 KB
Newer Older
每日一练社区's avatar
每日一练社区 已提交
1
# 成绩分析
F
fix bug  
feilong 已提交
2

3
**问题描述**
F
fix bug  
feilong 已提交
4

每日一练社区's avatar
每日一练社区 已提交
5 6 7 8
小蓝给学生们组织了一场考试,卷面总分为100分,每个学生的得分都是一个0到100的整数。

请计算这次考试的最高分、最低分和平均分。

9
**输入格式**
F
fix bug  
feilong 已提交
10

每日一练社区's avatar
每日一练社区 已提交
11 12 13 14
输入的第一行包含一个整数n,表示考试人数。

接下来n行,每行包含一个0至100的整数,表示一个学生的得分。

15
**输出格式**
F
fix bug  
feilong 已提交
16

每日一练社区's avatar
每日一练社区 已提交
17 18 19 20 21 22 23 24
输出三行。

第一行包含一个整数,表示最高分。

第二行包含一个整数,表示最低分。

第三行包含一个实数,四舍五入保留正好两位小数,表示平均分。

25
**样例输入**
每日一练社区's avatar
每日一练社区 已提交
26

F
fix bug  
feilong 已提交
27

每日一练社区's avatar
每日一练社区 已提交
28 29 30 31 32 33 34 35 36 37
```
7
80
92
56
74
88
99
10
```
38
**样例输出**
F
fix bug  
feilong 已提交
39

每日一练社区's avatar
每日一练社区 已提交
40 41 42 43 44 45 46
```
99
10
71.29
```

## aop
F
fix bug  
feilong 已提交
47

每日一练社区's avatar
每日一练社区 已提交
48
### before
F
fix bug  
feilong 已提交
49

每日一练社区's avatar
每日一练社区 已提交
50 51 52 53 54 55 56
```cpp
#include <stdio.h>
#include <iostream>

using namespace std;
```
### after
F
fix bug  
feilong 已提交
57

每日一练社区's avatar
每日一练社区 已提交
58 59 60 61 62
```cpp

```

## 答案
F
fix bug  
feilong 已提交
63

每日一练社区's avatar
每日一练社区 已提交
64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89
```cpp
int main()
{
    int n;
    cin >> n;
    int sum = 0;
    int top = 0;
    int low = 100;

    int score;
    for (int i = 0; i < n; i++)
    {
        cin >> score;
        if (score > top)
            top = score;
        if (score < low)
            low = score;
        sum += score;
    }
    printf("%d\n%d\n%.2lf", top, low, (sum * 1.0 / n));
    return 0;
}

```
## 选项

F
fix bug  
feilong 已提交
90

每日一练社区's avatar
每日一练社区 已提交
91
### A
F
fix bug  
feilong 已提交
92

每日一练社区's avatar
每日一练社区 已提交
93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117
```cpp
int main()
{
    int n;
    cin >> n;
    int sum = 0;
    int top = 0;
    int low = 100;

    int score;
    for (int i = 0; i < n; i++)
    {
        cin >> score;
        if (score > top)
            top = score;
        if (score < low)
            low = score;
        sum += score;
    }
    printf("%d\n%d\n%.f", top, low, (sum * 1.0 / n));
    return 0;
}
```

### B
F
fix bug  
feilong 已提交
118

每日一练社区's avatar
每日一练社区 已提交
119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143
```cpp
int main()
{
    int n;
    cin >> n;
    int sum = 0;
    int top = 0;
    int low = 100;

    int score;
    for (int i = 0; i < n; i++)
    {
        cin >> score;
        if (score > top)
            score = top;
        if (score < low)
            score = low;
        sum += score;
    }
    printf("%d\n%d\n%.2lf", top, low, (sum * 1.0 / n));
    return 0;
}
```

### C
F
fix bug  
feilong 已提交
144

每日一练社区's avatar
每日一练社区 已提交
145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167
```cpp
int main()
{
    int n;
    cin >> n;
    int sum = 0;
    int top = 0;
    int low = 100;

    int score;
    for (int i = 0; i < n; i++)
    {
        cin >> score;
        if (score < top)
            top = score;
        if (score > low)
            low = score;
        sum += score;
    }
    printf("%d\n%d\n%d", top, low, (sum / n));
    return 0;
}
```