提交 085be713 编写于 作者: H hue715

update to 11.0.5

from srchack/custom-packages.git
1、open-vm-tools: bump 11.0.5
2、open-vm-tools: Change PKG_LICENSE
上级 7f793310
......@@ -8,17 +8,19 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=open-vm-tools
PKG_VERSION:=10.3.10
PKG_VERSION:=11.0.5
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-12406962.tar.gz
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-15389592.tar.gz
PKG_SOURCE_URL:=https://github.com/vmware/open-vm-tools/releases/download/stable-$(PKG_VERSION)
PKG_HASH:=a3c02595c802680be258d6249513c76502d383a59597079b10984bb9136dbef5
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-12406962
PKG_HASH:=fc5ed2d752af33775250e0f103d622c0031d578f8394511617d2619b124dfc42
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-15389592
PKG_INSTALL:=1
PKG_BUILD_DEPENDS:=glib2/host
PKG_FIXUP:=autoreconf
PKG_LICENSE:=LGPL-2.1
PKG_LICENSE:=LGPL-2.1-or-later
PKG_LICENSE_FILES:=LICENSE
include $(INCLUDE_DIR)/package.mk
......
......@@ -10,12 +10,4 @@ diff -urN a/configure.ac b/configure.ac
[],
[dnet.h],
[intf_open],
@@ -959,7 +959,7 @@
if test $have_dnet = "no"; then
AC_MSG_ERROR(
- [dnet-config was not found on your PATH. Please configure without dnet (using --without-dnet) or install dnet - http://libdnet.sourceforge.net])
+ [dnet was not found. Please configure without dnet (using --without-dnet) or install dnet - http://libdnet.sourceforge.net])
fi
fi
......@@ -88,10 +88,10 @@ diff -urN a/lib/misc/idLinux.c b/lib/misc/idLinux.c
diff -urN a/lib/nicInfo/nicInfoPosix.c b/lib/nicInfo/nicInfoPosix.c
--- a/lib/nicInfo/nicInfoPosix.c
+++ b/lib/nicInfo/nicInfoPosix.c
@@ -34,9 +34,13 @@
#include <sys/socket.h>
@@ -35,9 +35,13 @@
#include <sys/stat.h>
#include <errno.h>
#include <limits.h>
-#if defined(__FreeBSD__) || defined(__APPLE__)
+#if HAVE_SYS_SYSCTL_H
# include <sys/sysctl.h>
......
diff --git a/lib/asyncsocket/asyncsocket.c b/lib/asyncsocket/asyncsocket.c
index e0a68e7e..b9675674 100644
index 07a5d04b..01181a95 100644
--- a/lib/asyncsocket/asyncsocket.c
+++ b/lib/asyncsocket/asyncsocket.c
@@ -86,7 +86,7 @@
......@@ -12,7 +12,7 @@ index e0a68e7e..b9675674 100644
#include "err.h"
#include "hostinfo.h"
diff --git a/lib/hgfsServer/hgfsServer.c b/lib/hgfsServer/hgfsServer.c
index 991a7941..ed0c09f9 100644
index 46224551..fc691286 100644
--- a/lib/hgfsServer/hgfsServer.c
+++ b/lib/hgfsServer/hgfsServer.c
@@ -48,7 +48,7 @@
......@@ -25,7 +25,7 @@ index 991a7941..ed0c09f9 100644
#include "vm_basic_asm.h"
#include "unicodeOperations.h"
diff --git a/lib/include/asyncsocket.h b/lib/include/asyncsocket.h
index 524147ea..103f944f 100644
index 95a5e464..a4b4e5aa 100644
--- a/lib/include/asyncsocket.h
+++ b/lib/include/asyncsocket.h
@@ -164,7 +164,7 @@ typedef struct AsyncSocket AsyncSocket;
......@@ -51,23 +51,11 @@ index 46442e55..8bc66997 100644
#if defined(__cplusplus)
diff --git a/lib/include/poll.h b/lib/include/vm_poll.h
similarity index 99%
rename from a/lib/include/poll.h
rename to a/lib/include/vm_poll.h
index 988fe6d0..e9e74fb5 100644
--- a/lib/include/poll.h
+++ b/lib/include/vm_poll.h
@@ -60,7 +60,7 @@ extern "C" {
#if !defined(TARGET_OS_IPHONE) || TARGET_OS_IPHONE == 0
#include <sys/kernel.h>
#endif
-#include <sys/poll.h>
+#include <poll.h>
#define HZ 100
#endif
#ifdef __ANDROID__
similarity index 100%
rename from lib/include/poll.h
rename to lib/include/vm_poll.h
diff --git a/lib/rpcIn/rpcin.c b/lib/rpcIn/rpcin.c
index c2c51583..d6c62f10 100644
index 47a3380e..660382c6 100644
--- a/lib/rpcIn/rpcin.c
+++ b/lib/rpcIn/rpcin.c
@@ -57,7 +57,7 @@
......@@ -79,16 +67,3 @@ index c2c51583..d6c62f10 100644
# include "asyncsocket.h"
# include "vmci_defs.h"
#include "dataMap.h"
diff --git a/services/plugins/grabbitmqProxy/grabbitmqProxyPlugin.c b/services/plugins/grabbitmqProxy/grabbitmqProxyPlugin.c
index 03700937..f0b49ad7 100644
--- a/services/plugins/grabbitmqProxy/grabbitmqProxyPlugin.c
+++ b/services/plugins/grabbitmqProxy/grabbitmqProxyPlugin.c
@@ -48,7 +48,7 @@
#include "rpcout.h"
#include "rabbitmqProxyConst.h"
#include "vm_basic_types.h"
-#include "poll.h"
+#include "vm_poll.h"
#ifdef OPEN_VM_TOOLS
#include "vmci_sockets.h"
#include "sslDirect.h"
diff -urNp open-vm-tools-11.0.5-15389592.ORG/lib/nicInfo/nicInfoPosix.c open-vm-tools-11.0.5-15389592/lib/nicInfo/nicInfoPosix.c
--- open-vm-tools-11.0.5-15389592.ORG/lib/nicInfo/nicInfoPosix.c 2020-01-20 15:12:46.004034669 +0000
+++ open-vm-tools-11.0.5-15389592/lib/nicInfo/nicInfoPosix.c 2020-01-20 15:40:44.370425791 +0000
@@ -65,6 +65,9 @@
#include <netinet/in.h>
#include <arpa/nameser.h>
#include <resolv.h>
+#if defined(__linux__) && !defined(__GLIBC__)
+#include "resolv_compat.h"
+#endif
#ifdef __linux__
# include <net/if.h>
diff -urNp open-vm-tools-11.0.5-15389592.ORG/lib/nicInfo/resolv_compat.h open-vm-tools-11.0.5-15389592/lib/nicInfo/resolv_compat.h
--- open-vm-tools-11.0.5-15389592.ORG/lib/nicInfo/resolv_compat.h 1970-01-01 00:00:00.000000000 +0000
+++ open-vm-tools-11.0.5-15389592/lib/nicInfo/resolv_compat.h 2020-01-20 15:39:09.397871457 +0000
@@ -0,0 +1,29 @@
+#if !defined(__GLIBC__)
+/***************************************************************************
+ * resolv_compat.h
+ *
+ * Mimick GLIBC's res_ninit() and res_nclose() for musl libc
+ * Note: res_init() is actually deprecated according to
+ * http://docs.oracle.com/cd/E36784_01/html/E36875/res-nclose-3resolv.html
+ **************************************************************************/
+#include <string.h>
+
+static inline int res_ninit(res_state statp)
+{
+ int rc = res_init();
+ if (statp != &_res) {
+ memcpy(statp, &_res, sizeof(*statp));
+ }
+ return rc;
+}
+
+static inline int res_nclose(res_state statp)
+{
+ if (!statp)
+ return -1;
+ if (statp != &_res) {
+ memset(statp, 0, sizeof(*statp));
+ }
+ return 0;
+}
+#endif
Markdown is supported
0% .
You are about to add 0 people to the discussion. Proceed with caution.
先完成此消息的编辑!
想要评论请 注册