1. 27 6月, 2019 3 次提交
  2. 18 6月, 2019 2 次提交
  3. 16 6月, 2019 2 次提交
  4. 15 6月, 2019 2 次提交
    • S
      batman-adv: Add support for hardif settings · 67875e20
      Sven Eckelmann 提交于
      B.A.T.M.A.N. V support additional settings which are hardif specific. The
      batadv_hardif proto has to expose them to allow automatic configuration.
      The default configuration would be:
      
        config interface 'bat0_hardif_eth0'
        	option proto 'batadv_hardif'
        	option master 'bat0'
        	option ifname 'eth0'
        	option mtu '1536'
        	option 'elp_interval' 500
        	# string like '1mbit' is accepted instead of kbit for override
        	option 'throughput_override' '0'
      Signed-off-by: NSven Eckelmann <sven@narfation.org>
      67875e20
    • S
      batctl: Add support for hardif settings · eeea3e98
      Sven Eckelmann 提交于
      batctl currently supports settings which are either mesh interface or vlan
      specific. But B.A.T.M.A.N. V introduced two additional settings which are
      hard (slave) interface specific.
      
      To support these, an additional command prefix called hardif is implemented
      for some sysfs commands:
      
        $ batctl -m bat0 hardif eth0 ..
      
      The usable commands with that are:
      
      * elp_interval
      * throughput_override
      Signed-off-by: NSven Eckelmann <sven@narfation.org>
      eeea3e98
  5. 03 6月, 2019 1 次提交
  6. 02 6月, 2019 1 次提交
    • S
      batman-adv: Fix duplicated OGMs on NETDEV_UP · e26096ae
      Sven Eckelmann 提交于
      The state of slave interfaces are handled differently depending on whether
      the interface is up or not. All active interfaces (IFF_UP) will transmit
      OGMs. But for B.A.T.M.A.N. IV, also non-active interfaces are scheduling
      (low TTL) OGMs on active interfaces. The code which setups and schedules
      the OGMs must therefore already be called when the interfaces gets added as
      slave interface and the transmit function must then check whether it has to
      send out the OGM or not on the specific slave interface.
      
      But v2016.3 moved the setup code from the enable function to the activate
      function. The latter is called either when the added slave was already up
      when batadv_hardif_enable_interface processed the new interface or when a
      NETDEV_UP event was received for this slave interfac. As result, each
      NETDEV_UP would schedule a new OGM worker for the interface and thus OGMs
      would be send a lot more than expected.
      
      Fixes: 549909f8 ("batman-adv: upgrade package to latest release 2016.3")
      Reported-by: NLinus Lüssing <linus.luessing@c0d3.blue>
      Signed-off-by: NSven Eckelmann <sven@narfation.org>
      e26096ae
  7. 27 5月, 2019 1 次提交
  8. 25 5月, 2019 2 次提交
  9. 24 5月, 2019 4 次提交
  10. 16 5月, 2019 1 次提交
  11. 08 5月, 2019 1 次提交
    • R
      nodogsplash: Release v3.3.2-1 (#468) · 040b8e87
      Rob White 提交于
      Maintainer: Moritz Warning <moritzwarning@web.de>
      
      Compiled and tested on snapshot SDK mips_24kc and arm_cortex-a5_neon-vfpv4/
      
        * Fix Issue introduced in v3.3.0 with the addition of Improvements towards usable IPv6 support, that caused CPD on client devices to fail with "Too Many Redirects" error. NDS now terminates gracefully with a console error if fasremoteip is set AND fasport=80  [bluewavenet]
        * Validate fasremoteip to ensure that if it is set, then it is a valid dotted format IPv4 address  [bluewavenet]
        * Numerous Documentation updates  [bluewavenet]
        * Fix to Known Issue on OpenWrt >18.x.x with v3.3.1. This was caused by misconfigured Makefile for libmicrohttpd; this has been fixed there [bluewavenet]
      Signed-off-by: NRob White <rob@blue-wave.net>
      040b8e87
  12. 01 5月, 2019 1 次提交
  13. 23 4月, 2019 1 次提交
  14. 01 4月, 2019 1 次提交
  15. 29 3月, 2019 5 次提交
  16. 26 3月, 2019 1 次提交
  17. 25 3月, 2019 1 次提交
  18. 23 3月, 2019 1 次提交
  19. 21 3月, 2019 1 次提交
  20. 20 3月, 2019 1 次提交
  21. 15 3月, 2019 1 次提交
  22. 14 3月, 2019 1 次提交
  23. 13 3月, 2019 1 次提交
  24. 09 3月, 2019 1 次提交
  25. 08 3月, 2019 2 次提交
    • S
      Merge pull request #453 from ecsv/batadv-2019.0 · b57b8dc6
      Simon Wunderlich 提交于
      batman-adv: Split batadv proto in meshif and hardif part
      b57b8dc6
    • S
      batman-adv: Split batadv proto in meshif and hardif part · 54af5a20
      Sven Eckelmann 提交于
      batman-adv allows to configure three different objects:
      
      * batadv hardif
      
        - network interface used by batadv meshif to transport the batman-adv
          packets
        - its master interface is set to the batadv meshif
      
      * batadv (meshif/softif)
      
        - virtual interface that emulates a normal 802.3 interface on top
        - encapsulates traffic and forwards it via the batadv hardifs
      
      * batadv vlan
      
        - potential VLAN ID on top of batadv meshif
        - allows filtering of traffic from specific VIDs
      
      While batadv vlan objects were already represented as an own proto
      "batadv_vlan", the batadv meshif could never be fully configured using
      /etc/config/network. Instead, parts of its configuration were stored in
      /etc/config/batman_adv and some in the interfaces with the "batadv" proto.
      
      To increase the confusion, the "batadv" proto wasn't used to define the
      batadv meshif but to identify batadv (slave) hardifs. The batman-adv
      meshifs were also never created directly but only when a hardif was
      configured. The actual modification of the configuration settings was then
      applied using a hotplug script hack. The batadv meshif network interface
      could therefore only be created when an hardif was available and not
      manipulated with ifup/ifdown. Also `/etc/init.d/network reload` didn't
      modify the batadv meshif interface configuration correctly.
      
      The "batadv" is now renamed to "batadv_hardif" and a new "batadv" proto is
      used to configure the main (meshif) network interface with all its
      configuration.
      
      A simple network configuration with WiFi & ethernet interfaces and static
      IP on top of bat0 would look like:
      
        # batadv meshif bat0
        config interface 'bat0'
        	option proto 'batadv'
        	option routing_algo 'BATMAN_IV'
        	option aggregated_ogms 1
        	option ap_isolation 0
        	option bonding 0
        	option fragmentation 1
        	#option gw_bandwidth '10000/2000'
        	option gw_mode 'off'
        	#option gw_sel_class 20
        	option log_level 0
        	option orig_interval 1000
        	option bridge_loop_avoidance 1
        	option distributed_arp_table 1
        	option multicast_mode 1
        	option network_coding 0
        	option hop_penalty 30
        	option isolation_mark '0x00000000/0x00000000'
      
        # add *single* wifi-iface with network bat0_hardif_wlan as hardif to bat0
        config interface 'bat0_hardif_wlan'
        	option mtu '1536'
        	option proto 'batadv_hardif'
        	option master 'bat0'
        	# option ifname is filled out by the wifi-iface
      
        # add eth0 as hardif to bat0
        config interface 'bat0_hardif_eth0'
        	option proto 'batadv_hardif'
        	option master 'bat0'
        	option ifname 'eth0'
        	option mtu '1536'
      
        # configure IP on bat0
        config interface 'bat0_lan'
        	option ifname 'bat0'
        	option proto 'static'
        	option ipaddr '192.168.1.1'
        	option netmask '255.255.255.0'
        	option ip6assign '60'
      Signed-off-by: NSven Eckelmann <sven@narfation.org>
      54af5a20
  26. 07 3月, 2019 1 次提交