solution.md 2.8 KB
Newer Older
每日一练社区's avatar
每日一练社区 已提交
1
# 成绩分析
F
fix bug  
feilong 已提交
2

3
**问题描述**
F
fix bug  
feilong 已提交
4

每日一练社区's avatar
每日一练社区 已提交
5 6 7 8
小蓝给学生们组织了一场考试,卷面总分为100分,每个学生的得分都是一个0到100的整数。

请计算这次考试的最高分、最低分和平均分。

9
**输入格式**
F
fix bug  
feilong 已提交
10

每日一练社区's avatar
每日一练社区 已提交
11 12 13 14
输入的第一行包含一个整数n,表示考试人数。

接下来n行,每行包含一个0至100的整数,表示一个学生的得分。

15
**输出格式**
F
fix bug  
feilong 已提交
16

每日一练社区's avatar
每日一练社区 已提交
17 18 19 20 21 22 23 24
输出三行。

第一行包含一个整数,表示最高分。

第二行包含一个整数,表示最低分。

第三行包含一个实数,四舍五入保留正好两位小数,表示平均分。

25
**样例输入**
每日一练社区's avatar
每日一练社区 已提交
26

F
fix bug  
feilong 已提交
27

每日一练社区's avatar
每日一练社区 已提交
28 29 30 31 32 33 34 35 36 37
```
7
80
92
56
74
88
99
10
```
38
**样例输出**
F
fix bug  
feilong 已提交
39

每日一练社区's avatar
每日一练社区 已提交
40 41 42 43 44 45
```
99
10
71.29
```

每日一练社区's avatar
每日一练社区 已提交
46 47
以下选项错误的是?

每日一练社区's avatar
每日一练社区 已提交
48
## aop
F
fix bug  
feilong 已提交
49

每日一练社区's avatar
每日一练社区 已提交
50
### before
F
fix bug  
feilong 已提交
51

每日一练社区's avatar
每日一练社区 已提交
52
```cpp
每日一练社区's avatar
每日一练社区 已提交
53
#include <bits/stdc++.h>
每日一练社区's avatar
每日一练社区 已提交
54 55 56
using namespace std;
```
### after
F
fix bug  
feilong 已提交
57

每日一练社区's avatar
每日一练社区 已提交
58 59 60 61 62
```cpp

```

## 答案
F
fix bug  
feilong 已提交
63

每日一练社区's avatar
每日一练社区 已提交
64 65 66 67 68 69
```cpp
int main()
{
    int n;
    cin >> n;

每日一练社区's avatar
每日一练社区 已提交
70
    int maxv = 0, minv = 100, sum = 0;
每日一练社区's avatar
每日一练社区 已提交
71 72
    for (int i = 0; i < n; i++)
    {
每日一练社区's avatar
每日一练社区 已提交
73 74 75 76 77
        int x;
        cin >> x;
        minv = min(minv, x);
        maxv = max(maxv, x);
        sum += x;
每日一练社区's avatar
每日一练社区 已提交
78
    }
每日一练社区's avatar
每日一练社区 已提交
79 80 81 82

    cout << maxv << endl;
    cout << minv << endl;
    printf("%.2f", sum / n);
每日一练社区's avatar
每日一练社区 已提交
83 84 85 86 87
    return 0;
}
```
## 选项

F
fix bug  
feilong 已提交
88

每日一练社区's avatar
每日一练社区 已提交
89
### A
F
fix bug  
feilong 已提交
90

每日一练社区's avatar
每日一练社区 已提交
91 92 93
```cpp
int main()
{
每日一练社区's avatar
每日一练社区 已提交
94 95
    int n, max = 0, min = 0;
    double sum = 0, average = 0;
每日一练社区's avatar
每日一练社区 已提交
96
    cin >> n;
每日一练社区's avatar
每日一练社区 已提交
97 98 99 100 101 102
    int a[10000];
    cin >> a[0];
    sum = a[0];
    max = a[0];
    min = a[0];
    for (int i = 1; i < n; i++)
每日一练社区's avatar
每日一练社区 已提交
103
    {
每日一练社区's avatar
每日一练社区 已提交
104 105 106 107 108 109 110 111 112 113
        cin >> a[i];
        if (max < a[i])
        {
            max = a[i];
        }
        if (min > a[i])
        {
            min = a[i];
        }
        sum += a[i];
每日一练社区's avatar
每日一练社区 已提交
114
    }
每日一练社区's avatar
每日一练社区 已提交
115 116 117 118 119
    average = sum / n;
    cout << max << endl
         << min << endl
         << setiosflags(ios::fixed) << setprecision(2) << average;

每日一练社区's avatar
每日一练社区 已提交
120 121 122 123 124
    return 0;
}
```

### B
F
fix bug  
feilong 已提交
125

每日一练社区's avatar
每日一练社区 已提交
126
```cpp
每日一练社区's avatar
每日一练社区 已提交
127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154
int n;

int Max(int m[10005])
{
    int max = m[0];
    for (int i = 1; i < n; i++)
    {
        if (max < m[i])
        {
            max = m[i];
        }
    }
    return max;
}

int Min(int m[10005])
{
    int min = m[0];
    for (int i = 1; i < n; i++)
    {
        if (min > m[i])
        {
            min = m[i];
        }
    }
    return min;
}

每日一练社区's avatar
每日一练社区 已提交
155 156 157
int main()
{
    cin >> n;
每日一练社区's avatar
每日一练社区 已提交
158 159 160 161 162 163 164
    int m[10005];
    for (int i = 0; i < n; i++)
    {
        cin >> m[i];
    }

    int ans = 0;
每日一练社区's avatar
每日一练社区 已提交
165 166 167

    for (int i = 0; i < n; i++)
    {
每日一练社区's avatar
每日一练社区 已提交
168
        ans += m[i];
每日一练社区's avatar
每日一练社区 已提交
169
    }
每日一练社区's avatar
每日一练社区 已提交
170 171 172 173 174 175 176

    int a = Max(m);
    int b = Min(m);

    cout << "最高分 = " << a << endl;
    cout << "最低分 = " << b << endl;
    printf("%.2lf", 1.0 * ans / n);
每日一练社区's avatar
每日一练社区 已提交
177 178 179 180 181
    return 0;
}
```

### C
F
fix bug  
feilong 已提交
182

每日一练社区's avatar
每日一练社区 已提交
183 184 185 186 187 188 189 190 191 192 193 194 195
```cpp
int main()
{
    int n;
    cin >> n;
    int sum = 0;
    int top = 0;
    int low = 100;

    int score;
    for (int i = 0; i < n; i++)
    {
        cin >> score;
每日一练社区's avatar
每日一练社区 已提交
196
        if (score > top)
每日一练社区's avatar
每日一练社区 已提交
197
            top = score;
每日一练社区's avatar
每日一练社区 已提交
198
        if (score < low)
每日一练社区's avatar
每日一练社区 已提交
199 200 201
            low = score;
        sum += score;
    }
每日一练社区's avatar
每日一练社区 已提交
202
    printf("%d\n%d\n%.2lf", top, low, (sum * 1.0 / n));
每日一练社区's avatar
每日一练社区 已提交
203 204 205
    return 0;
}
```