solution.md 2.7 KB
Newer Older
每日一练社区's avatar
每日一练社区 已提交
1 2
# 分类计数

3
**问题描述**
F
fix bug  
feilong 已提交
4

每日一练社区's avatar
每日一练社区 已提交
5 6
输入一个字符串,请输出这个字符串包含多少个大写字母,多少个小写字母,多少个数字。

7
**输入格式**
F
fix bug  
feilong 已提交
8

每日一练社区's avatar
每日一练社区 已提交
9 10
输入一行包含一个字符串。

11
**输出格式**
F
fix bug  
feilong 已提交
12

每日一练社区's avatar
每日一练社区 已提交
13 14
输出三行,每行一个整数,分别表示大写字母、小写字母和数字的个数。

15
**样例输入**
F
fix bug  
feilong 已提交
16

每日一练社区's avatar
每日一练社区 已提交
17 18 19
```
1+a=Aab
```
20
**样例输出**
F
fix bug  
feilong 已提交
21

每日一练社区's avatar
每日一练社区 已提交
22 23 24 25 26
```
1 
3 
1
```
27
**评测用例规模与约定**
F
fix bug  
feilong 已提交
28

每日一练社区's avatar
每日一练社区 已提交
29 30 31 32
对于所有评测用例,字符串由可见字符组成,长度不超过 100。


## aop
F
fix bug  
feilong 已提交
33

每日一练社区's avatar
每日一练社区 已提交
34
### before
F
fix bug  
feilong 已提交
35

每日一练社区's avatar
每日一练社区 已提交
36 37 38 39 40
```cpp
#include <iostream>
using namespace std;
```
### after
F
fix bug  
feilong 已提交
41

每日一练社区's avatar
每日一练社区 已提交
42 43 44 45 46
```cpp

```

## 答案
F
fix bug  
feilong 已提交
47

每日一练社区's avatar
每日一练社区 已提交
48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78
```cpp
int main(int argc, char **argv)
{
    string str;
    cin >> str;
    int A = 0, a = 0, number = 0;
    int len = str.length();
    for (int i = 0; i < len; i++)
    {
        if (str[i] <= '9' && str[i] >= '0')
        {
            number++;
        }
        if (str[i] <= 'Z' && str[i] >= 'A')
        {
            A++;
        }
        if (str[i] <= 'z' && str[i] >= 'a')
        {
            a++;
        }
    }
    cout << A << endl;
    cout << a << endl;
    cout << number << endl;
    return 0;
}

```
## 选项

F
fix bug  
feilong 已提交
79

每日一练社区's avatar
每日一练社区 已提交
80
### A
F
fix bug  
feilong 已提交
81

每日一练社区's avatar
每日一练社区 已提交
82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111
```cpp
int main(int argc, char **argv)
{
    string str;
    cin >> str;
    int A = 0, a = 0, number = 0;
    int len = str.length();
    for (int i = 0; i < len; i++)
    {
        if (str[i] < '9' && str[i] > '0')
        {
            number++;
        }
        if (str[i] < 'Z' && str[i] > 'A')
        {
            A++;
        }
        if (str[i] < 'z' && str[i] > 'a')
        {
            a++;
        }
    }
    cout << A << endl;
    cout << a << endl;
    cout << number << endl;
    return 0;
}
```

### B
F
fix bug  
feilong 已提交
112

每日一练社区's avatar
每日一练社区 已提交
113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142
```cpp
int main(int argc, char **argv)
{
    string str;
    cin >> str;
    int A = 0, a = 0, number = 0;
    int len = str.length();
    for (int i = 0; i < len; i++)
    {
        if (str[i] < 71 && str[i] > 60)
        {
            number++;
        }
        if (str[i] < 132 && str[i] > 101)
        {
            A++;
        }
        if (str[i] < 172 && str[i] > 141)
        {
            a++;
        }
    }
    cout << A << endl;
    cout << a << endl;
    cout << number << endl;
    return 0;
}
```

### C
F
fix bug  
feilong 已提交
143

每日一练社区's avatar
每日一练社区 已提交
144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171
```cpp
int main(int argc, char **argv)
{
    string str;
    cin >> str;
    int A = 0, a = 0, number = 0;
    int len = str.length();
    for (int i = 0; i < len; i++)
    {
        if (str[i] < 39 && str[i] > 30)
        {
            number++;
        }
        if (str[i] < 132 && str[i] > 101)
        {
            A++;
        }
        if (str[i] <= 'z' && str[i] >= 'a')
        {
            a++;
        }
    }
    cout << A << endl;
    cout << a << endl;
    cout << number << endl;
    return 0;
}
```